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From desktop GIS to Internet GIS

• The usage of the Web as a platform for distributing geospatial data has 

been favored by a set of typical characteristics:

o traveling on the Web, data is independent of the platform used

o data can be easily and quickly updated

o data can be reached by a wide and distributed public

o costs are very limited compared to those for printing/updating maps

o the Web allows an interactive and dynamic data presentation

o data exchange is regulated by diffused and shared standards

• When a GIS application is shared on the Web, it is freed from the 

constraints represented by the machine containing the data, thus 

becoming an Internet GIS or WebGIS.



Internet GIS architecture

• Accessing a WebGIS, cartographic and/or alphanumeric data can be 

visualized, browsed and downloaded from users through an easy to use 

interface (client) accessible with a common browser or other software, an 

Internet connection, and eventually a security authentication.

• Standard architecture:



QGIS Server introduction

• QGIS Server, which is part of the QGIS open source project, is a 

FastCGI/CGI (Common Gateway Interface) application written in C++ 

and working together with a web server (e.g. Apache).

• It provides web geospatial services using QGIS as back end for the GIS 

logic and for map rendering:

o implemented standards are WMS, WFS, WCS & SLD

o maps and print templates created in QGIS desktop can be directly 

published as web maps, which look the same as in the desktop.

• As part of QGIS (https://www.qgis.org), QGIS Server is licensed under 

the GNU General Public License (GPL) and is an official project of the 

Open Source Geospatial Foundation (OSGeo).



QGIS Server introduction

• QGIS Server only provides an OGC map server, i.e. it allows to expose 

geospatial data on the web using OGC web services; to consume data 

(i.e. visualize, navigate and query it), an OGC web client is then required.

• There are essentially two ready-to-use web clients for QGIS Server:

o Lizmap

o QGIS Web Client



QGIS Server – Get started

• To start QGIS Server:

o click the Start button at the bottom left, then select Geospatial → 

Web Services → QGIS Server

o alternatively, open the folder Web Services on the desktop and 

double click on QGIS Server



QGIS Server – Get started

• A browser window appears with a web map viewer showing a world map:

o the viewer is built with the GeoExt JS framework (http://geoext.org)

o the same web page can be accessed at http://localhost/qgis_server



Link between QGIS and QGIS Server

• Open QGIS from Geospatial → Desktop GIS → QGIS:

o from the menu Project → Open, select the QGIS project file named 

QGIS-NaturalEarth-Example.qgs, located in /var/www/html/qgis 

• You should see the same world map rendered by QGIS.



Link between QGIS and QGIS Server

• Change the editing permission of the folder /var/www/html/qgis by typing 

in the terminal sudo chmod –R 777 /var/www/html/qgis 

• Change the color of the rivers and the lakes (layer group Water) and save 

the edits from the menu Project → Save.

• Re-open the web browser and see the rivers and lakes rendered by QGIS 

Server in the same new color.



Link between QGIS and QGIS Server

• Open the file index.html, located in /var/www/html/qgis_server, which is 

the HTML file corresponding the web page showing the world map:

• The code above shows that:

o QGIS Server publishes WMS layers taken from the QGIS project file 

QGIS-NaturalEarth-Example.qgs

o only the 3 layers HYP_50M_SR_W, ne_10m_lakes and 

ne_10m_rivers_lake_centerlines are retrieved from the project

o these 3 layers are combined into a single layer, used as a basemap 

(see the radio button in the web map)



Link between QGIS and QGIS Server

• Open a new QGIS project from the menu Project → New.

• From the menu Layer → Add Layer → Add Vector Layer, add the shapefile 

/home/user/data/natural_earth2/ne_10m_admin_0_countries.shp.

• From Project → Save, save the QGIS project file as /home/user/world.qgs.



Link between QGIS and QGIS Server

• In the web browser, paste this URL to make a WMS GetMap request to the 

same layer published by QGIS Server: localhost/cgi-

bin/qgis_mapserv?map=/home/user/world.qgs&SERVICE=WMS&VERSIO

N=1.3.0&REQUEST=GetMap&BBOX=-91.901820,-

180.000000,83.633800,180.000000&CRS=EPSG:4326&WIDTH=722&HEI

GHT=352&LAYERS=ne_10m_admin_0_countries&STYLES=default&FOR

MAT=image/png&DPI=96&TRANSPARENT=true



Link between QGIS and QGIS Server

• Change the layer style in QGIS:

o use a categorized style according to the continent field

• Save the QGIS project file and repeat the same WMS GetMap request:



Link between QGIS and QGIS Server

• The URL of the WMS GetMap request can be manipulated, by changing:

o the QGIS project file from where the layer has to be retrieved

o the layer name, as it appears in the QGIS project file

o the bounding box where the layer has to be represented

o the width and height of the image file to be returned on the browser 

• Try e.g. with this request: http://localhost/cgi-

bin/qgis_mapserv?map=/var/www/html/qgis/QGIS-NaturalEarth-

Example.qgs&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&

BBOX=-90,-

180,90,180&CRS=EPSG:4326&WIDTH=900&HEIGHT=500&LAYERS=n

e_10m_lakes&STYLES=default&FORMAT=image/png&DPI=96&TRANS

PARENT=true



Link between QGIS and QGIS Server

• A single WMS GetMap request can also return a combination of two or 

more layers, which must be listed in the desired order of appearance, e.g. 

http://localhost/cgi-bin/qgis_mapserv?map=/var/www/html/qgis/QGIS-

NaturalEarth-

Example.qgs&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&

BBOX=-90,-

180,90,180&CRS=EPSG:4326&WIDTH=900&HEIGHT=500&LAYERS=n

e_10m_lakes,ne_10m_rivers_lake_centerlines&STYLES=default&FORM

AT=image/png&DPI=96&TRANSPARENT=true



Link between QGIS and QGIS Server

• A single WMS GetMap request can also return a combination of two or 

more layers:



Link between QGIS and QGIS Server

• A WMS GetCapabilities request corresponding to the same QGIS project 

file can be performed with the following URL: http://localhost/cgi-

bin/qgis_mapserv?map=/var/www/html/qgis/QGIS-NaturalEarth-

Example.qgs&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapab

ilities



Link between QGIS and QGIS Server

• The configuration of the QGIS OWS (OGC Web Server) can be 

configured from the QGIS menu Project → Project Properties, under the 

OWS tab: 

general server settings (metadata)
WMS server configuration
WFS server configuration
WCS server configuration
formal checks on available layers



Lizmap

• Lizmap is the most modern and efficient web client for QGIS Server:

o designed by the French company 3Liz (https://www.3liz.com/en)

o current version 3.2, code available under the open source Mozilla 

Public License (MPL) at https://github.com/3liz/lizmap-web-client

o documentation available at https://docs.3liz.com/en

• It generates web mapping applications from QGIS, using QGIS Server.
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Lizmap

• Publishing a web map with Lizmap happens in 3 steps:

o configuration of publishing options and tools of the QGIS project 

through the Lizmap plugin

o transfer of the geospatial data and the QGIS project on a map server, 

where the Lizmap web client is installed, with QGIS Server

o web map access through a web browser



Lizmap – Examples 

• Map of the flood risks in Montpellier, France:

o https://demo.lizmap.com/lizmap_3_0/index.php/view/map/?repository

=demo&project=pprn_montpellier



Lizmap – Examples 

• Map of demonstration of the faunistic observations in Polynesia:

o https://demo.lizmap.com/lizmap_3_0/index.php/view/map/?repository

=demo&project=observatoire



Lizmap – Examples 

• Map of Paris by night:

o https://demo.lizmap.com/lizmap_3_0/index.php/view/map/?repository

=demo&project=lampadaires



Lizmap – Get started 

• From the menu Plugins → Manage and Install Plugins, install the lizmap

QGIS plugin:

o the plugin will be available from the menu Web → Lizmap → lizmap

o the plugin works after opening or creating a QGIS project file



Lizmap – Get started 

• Lizmap web client needs to be installed, since it is not available on the 

OSGeo Live:

o it requires that both Apache web server and QGIS Server are already 

installed (they are available on the OSGeo Live)

o a brief installation guide is available at https://github.com/3liz/lizmap-

web-client/blob/master/INSTALL.md

o to avoid the installation steps, install Lizmap by following these tasks:

• download the script setup.sh from the course website and place 

it under the folder /home/user/Downloads

• open a terminal and type the following commands:      

cd home/user/Downloads/

sudo chmod 777 setup.sh

./setup.sh



Lizmap – Get started 

• To start Lizmap, open a web browser at http://localhost/lizmap/lizmap/www:

o you will see the homepage of the Lizmap web client, showing the  

demo repository Montpellier – Transports (included in the installation)



Lizmap – Get started 

• Click on View metadata to access the metadata of the repository. 

• Click on Load the map to open the Lizmap web map interface:
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Lizmap – Create your first web map

• In the folder /var/www/html/lizmap/lizmap/install, create a new folder 

named Ecuador. 

• Copy the data folder downloaded from the course website inside the 

folder Ecuador. 

• Create a new QGIS project showing some of the Ecuador data, and save 

it as Ecuador.qgs in the same folder Ecuador.



Lizmap – Create your first web map

• In the Lizmap plugin, under the Map options tab, set the general properties 

for the map: available tools and scales, initial extent and interface settings.



Lizmap – Create your first web map

• In the Lizmap plugin, under the Layers tab, define the settings for each of 

the available layers: title, abstract, legend, popup and map options.   



Lizmap – Create your first web map

• In the Lizmap plugin, under the Baselayers tab, select the basemap(s) 

you want to include in the web map along with ther properties.   



Lizmap – Create your first web map

• In the Lizmap plugin, under the Locate by layer tab, add the layer(s) you 

want to make available for search and selection in the web map. 



Lizmap – Create your first web map

• In the Lizmap plugin, under the Attribute table tab, add the layer(s) you 

want to make available for displaying the attribute table in the web map.



Lizmap – Create your first web map

• Click Apply to update the Lizmap configuration file for the project.

• Open the Lizmap homepage and click the Connect button in the top right 

corner, then login with the username admin and the password admin:

o you can now configure Lizmap as an administrator!

• Click the admin button in the top right corner and select My account.

• On the left menu, select Lizmap configuration.



• Scroll down the page to the Repository section, and click the button 

Create a repository.

Lizmap – Create your first web map

• Create the repository corresponding to the Ecuador QGIS project by filling 

in the required information as follows:



• Assign the relevant permissions to the new repository by checking the 

relevant checkboxes: 

Lizmap – Create your first web map



• Click the Projects button in the top right corner:

o now the project list shows also the Ecuador map project

o click the Load the map button to access to the web map

Lizmap – Create your first web map



• The web map will have all the properties previously set in QGIS: 

Lizmap – Create your first web map



QGIS Web Client (QWC)

• A web client based on other open source components:

o QWC1 (not maintained anymore): based on OpenLayers 2, GeoExt 

and ExtJS – https://github.com/qgis/QGIS-Web-Client 

o QWC2: based on OpenLayers 3 and MapStore 2 – demo available at

https://github.com/qgis/qwc2-demo-app

o Extended QGIS-Web-Client: a modified version of QWC1 with many 

additional features – https://github.com/joshcp/gisapp



QGIS Web Client (QWC) – Examples 

• Client of the General Regulatory Plan GIS of Asti municipality, Italy:

o http://sit.comune.asti.it/site/?map=PRGAsti



QGIS Web Client (QWC) – Examples 

• Client of the City of Uster, Switzerland:

o https://webgis.uster.ch/maps/energie/energieplan_2013 
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