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Before starting...

✓ Be sure to have downloaded the folder “QGIS_ho_wf” and the OSGeoLive 
VM is properly installed on our laptop
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> R
> install.packages("randomForest")



Lecture program and goals

✓ Taste the power of QGIS for geodata managing and processing 

✓ Topics

● Retrieve satellite images with QGIS
○ Basemaps
○ Open satellite imagery 

● Satellite images preprocessing
○ Import bands + atmospheric correction
○ Band set
○ Virtual rasters
○ Clip
○ Styling a multispectral raster layer

● Raster calculator

● Advanced vector layers editing 

● Extending QGIS functionalities
○ Add a custom script to the Processing Toolbox
○ Perform a supervised image classification for built-up areas
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Retrieve satellite images with QGIS: Basemaps  
✓ Open QGIS. On the Bar Menu select Plugin → Menage and install Plugins to activate the  

QuickMapServices Plugin. This Plugin provides a collection of ‘easy-to-add’ basemaps to 
be used in your QGIS projects  
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Retrieve satellite images with QGIS: Basemaps  
✓ Import into your QGIS the layers:

○ wa.shp
○ wa_preview.tif
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Retrieve satellite images with QGIS: Basemaps  
✓ On the Bar Menu select Web → QuickMapServices → Settings → More services → Get 

contributed pack to activate a richer collection of basemaps  
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Retrieve satellite images with QGIS: Basemaps  
✓ Select and activate a basemaps to better understand and contextualize the working area 

(wa) for this exercise  



Skills notebook

Activate basemaps from external providers for your QGIS project 
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Retrieve satellite images with QGIS: Open satellite imagery 
✓ On the Bar Menu select Plugin → Menage and install Plugins to activate the  

Semi-Automatic Classification Plugin 
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✓ The Semi-Automatic Classification Plugin (SCP) is a free open source plugin for QGIS that allows 
for the semi-automatic classification (also supervised and unsupervised classification) of remote 
sensing images. It provides several tools for the download of free images (Landsat, Sentinel-2, 
Sentinel-3, ASTER, MODIS), the preprocessing of images, the postprocessing of classifications, and 
the raster calculation

Bar Menu

Command 
panelDock
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Retrieve satellite images with QGIS: Open satellite imagery 

http://www.qgis.org/


✓ We are going to query and browse the data catalogue of the ESA Sentinel-2 mission. 
This is enabled by the Copernicus Open Access Hub which provides developers and data 
users with a set of API to access the imagery catalogue

✓ The API is implemented within the SCP Plugin by enabling the access to Sentinel-2 
imagery data (and many others) directly from QGIS

✓ Users must be authenticated to access these services. You can create your personal 
account at any time here (not compulsory for this exercise)
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Retrieve satellite images with QGIS: Open satellite imagery 

https://www.esa.int/spaceinimages/Missions/Sentinel-2
https://scihub.copernicus.eu/
https://en.wikipedia.org/wiki/Application_programming_interface
https://scihub.copernicus.eu/dhus/#/self-registration


✓ On the Bar Menu select SCP → Download Images → Sentinel-2 download. Insert the 
Login information and specify the Search area and date. To run the Search press 
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Retrieve satellite images with QGIS: Open satellite imagery 



✓ The images list is now downloaded. Select the image of your interest (see the 
ImageName selected in the figure). Press        to preview the selected image in the QGIS 
Map panel
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Retrieve satellite images with QGIS: Open satellite imagery 



✓ The selected image is previewed to your QGIS project
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Retrieve satellite images with QGIS: Open satellite imagery 



✓ To download and save the selected image press

✓ The image bands will be automatically imported in your QGIS project as .tif layers and the 
directory containing the whole Sentinel-2 imagery (.SAFE) will be save into your local 
memory (the imagery directory for this exercise is available at: QGIS_ho_wf -> input_data)
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Retrieve satellite images with QGIS: Open satellite imagery 



Skills notebook

Activate basemaps from external providers for your QGIS project 

Search and download satellite imagery data from QGIS
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✓ The Sentinel-2 imagery directory
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Satellite images preprocessing: Import bands + atmospheric correction

Matadata file

Bands data 



✓ On the Bar Menu select SCP → Preprocessing → Sentinel 2. Enter the directory 
containing the Bands data and the Metadata file
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Satellite images preprocessing: Import bands + atmospheric correction



✓ Select Bands 1, 9, 10 and remove them from the list by clicking on
✓ These Bands (60m) will not be considered later for this exercise 
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Satellite images preprocessing: Import bands + atmospheric correction



✓ Check the box Apply DOS1 atmospheric correction and press        to start the 

preprocessing

✓ This might take several minutes
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Satellite images preprocessing: Import bands + atmospheric correction



✓ The Bands are preprocessed (.tif formatting + surface reflectance adjustment), saved into 
your local memory, and imported in your QGIS project (with the “RT_” prefix)
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Satellite images preprocessing: Import bands + atmospheric correction



✓ To create a composite raster (multispectral imagery) of your scene, first you need to define a Band 
set specifying an order to stack the selected band data in the composite raster 

✓ On the Bar Menu select SCP → Band set . Load and order all the bands (as shown in the figure). 
Activate the option Quick wavelength settings → Sentinel 2  to automatically set the center 
wavelengths
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Satellite images preprocessing: Band set



✓ A clever way of saving “by-product” raster layers is the Virtual Raster format (.vrt). It consists of a text 
file pointing on multiple raster datasets which can be read and manipulated as a single layer

 
✓ Check the box Create a virtual raster of band set and press         to create a composite 

(multispectral) raster from your raster Bands according to the defined Band set. 
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Satellite images preprocessing: Virtual raster



 
✓ The Virtual raster (.vrt) is saved into your local memory and imported in your QGIS project
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Satellite images preprocessing: Virtual raster



✓ To obtain a composite raster layer covering only the working area, thus preventing further processing on 
the full raster layer (i.e. save time!), we can Clip the full Virtual raster layer on a region of interest and 
save the results as a “real” layer (.tif)

✓ On the Bar Menu activate the Processing Toolbox. Here, look for GDAL → Extraction→ Clip a raster 
by mask layer. Define the parameter for the clipping task (as shown in the figure) and press Run
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Satellite images preprocessing: Clip



✓ The clipped raster layer (.tif) is saved into your local memory and imported in your QGIS 
project (this will be used later to perform a supervised classification)
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Satellite images preprocessing: Clip



✓ To define a style for a multispectral image, open the layer Properties → Style→ 
Multiband Color and specify the Bands you want to visualize. According to the Sentinel-2 
imagery and our Band set, to obtain a natural color view (i.e. RGB), set the bands as 
shown in the figure. (Hints: for a better visualization, use the command Local Histogram 
Stretch        )
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Satellite images preprocessing: Styling a multispectral raster layer



Skills notebook

Activate basemaps from external providers for your QGIS project 

Search and download satellite imagery data from QGIS

Full preprocessing of multispectral satellite imagery with QGIS using both Plugins 
and Processing algorithms
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✓ The Raster Calculator allows you to perform calculations on the basis of existing raster 
pixel values

✓ QGIS provides with different solutions for performing raster calculus, e.g.:
○ QGIS (core) Raster calculator
○ GDAL Raster calculator
○ SAGA GIS Raster calculator
○ SCP Band calc
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Raster calculator



✓ On the Bar Menu select SCP → Band calc .  Refresh the bands list by clicking 
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Raster calculator: The SCP Band calc



✓ Let’s compute now simple graphical indicators that can be used to analyze remote sensing data, 
namely:

○ The Normalized Difference Vegetation Index (NDVI). The NDVI is the most well known and used vegetation 
index. It is a simple, but effective for quantifying green vegetation. The NDVI normalizes green leaf scattering in 
the near-infrared wavelength and chlorophyll absorption in the red wavelength [eq: (B8 - B4) / (B8 + B4)]

○ The Normalized Difference Built-up Index (NDBI). The NDBI highlights urban areas with higher reflectance in 
the shortwave-infrared (SWIR) region, compared to the Near Infrared (NIR) region [eq: (B11 - B8) / (B11 + B8)]

✓ On the SCP → Band calc .  Type the equations (see the figure), select the option Extent → Same as 
→ wa_preview (to compute automatically the output on the working area only), and define an output 
folder for the raster layer 
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Raster calculator: The SCP Band calc

https://www.sentinel-hub.com/eoproducts/ndvi
https://www.sentinel-hub.com/eoproducts/ndbi


✓ The computed raster layers are saved in your local memory and added to your QGIS 
project
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Raster calculator: The SCP Band calc



✓ A possible improvement of the automatic classification of built-up areas can be obtained by 
correcting the NDBI using the NDVI as Built-up = NDBI - NDVI (Masek et al. 2000)

✓ On the Bar Menu open Raster → Raster Calculator .  Type the above equation and 
define the features of the output layer (see the figure)
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Raster calculator: QGIS (core) raster calculator



✓ In order to create a classification raster (built-up = 1 / non built-up = 0), we can create a 
Conditional Raster using the Raster Calculator  by setting a threshold on the Built-up 
values (see the figure)
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Raster calculator: QGIS (core) raster calculator



✓ The classified raster layer is saved in your local memory and added to your QGIS project

✓ Visually compare the obtained classification with the reference natural color imagery 
(clip.tif or wa_overview.tif) and make your judgments
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Raster calculator: QGIS (core) raster calculator



Skills notebook

Activate basemaps from external providers for your QGIS project 

Search and download satellite imagery data from QGIS

Full preprocessing of multispectral satellite imagery with QGIS using both Plugins 
and Processing algorithms

Manipulate raster bands to compute graphical indicators and conditional rasters for 
analysing remote sensing data
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✓ Let’s now try to perform a supervised classification for the preprocessed images, by following the 
previously attempted classification of built-up areas. 

✓ First, we need to define training areas within our working area. These will be edited manually as a 
multi-polygon shapefile which will contain an attribute field describing the belonging of each polygon 
to the classes: 0 = non bulti-up, 1 = built-up. (Assign the same CRS of the multispectral clipped raster 
layer we create before!)

✓ On the Bar Menu select Layer → Create layer →New shapefile layer.  Define first a type and a name 
for the new layer and second, specify its attributes (see the figure)
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Advanced vector layers editing



✓ Right click on the layer name and select  Toggle Editing 

✓ Right click on the layer name and select  Properties → Fields. For the ‘class’ attribute modify the Edit 
widget to Value Map. Specify two classes of value: 0 = non bulti-up, 1 = built-up, then press Ok. The 
Value Map option helps to edit the attribute of any new geometry drawn in the new shapefile layer. This 
will assign labels to your values (0,1) to facilitate the editing task 
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Advanced vector layers editing



✓ Start to digitalize the training areas by selecting from the Bar Menu Edit → Add feature  

✓ Click on the Map panel to create the polygon vertices, Right-click to end the polygon drawing. Use a 
natural color imagery of the working area as reference. Once the drawing is done, define the type of 
class with the attribute Editing widget

✓ Create a suitable amount of polygons (for this exercise ̴ 15) trying to cover any different situation for 
built-up and non built-up areas (e.g. sand, crops, dense buildings, scattered buildings, roads, etc.) in the 
working area.
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Advanced vector layers editing



✓ To conclude the editing and save the changes press the Toggle Editing  

✓ Your new shapefile layer now contains the training areas for performing a supervised 
classification. The quality of this latter strongly depends on the quality of the selected (and 
mapped) training areas
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Advanced vector layers editing



Skills notebook

Activate basemaps from external providers for your QGIS project 

Search and download satellite imagery data from QGIS

Full preprocessing of multispectral satellite imagery with QGIS using both Plugins 
and Processing algorithms

Manipulate raster bands to compute graphical indicators and conditional rasters for 
analysing remote sensing data

Edit vector layers in QGIS and speed-up the editing of attributes using the Value 
Map option
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✓ QGIS does not provide always core functionalities to accomplish complex geoprocessing such as 
images classification. Nevertheless QGIS can be extended with processing tools both from external 
providers as well as programmed by the users. This is allowed by the Processing Toolbox

 
✓ In this exercise, we will see how to import a custom R script enabling to perform supervised image 

classifications using the Random Forest algorithm 

✓ On the Bar Menu select Processing→ Options →Providers and Activate the R scripts. Then, 
activate the Toolbox
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Extending QGIS functionalities: Add a custom script to the Processing Toolbox 

https://cran.r-project.org/web/packages/randomForest/index.html


✓ On the Processing Toolbox panel go on R scripts →Create new R script. Open text file ‘RF_gr’ you 
can find in the exercise data folder at: ‘QGIS_ho_wf’ -> ‘Rscripts’. Copy the text of the file in the Script 
editor and save it (do not change the suggest path during the save operation!) 

✓ The script will appear under Processing Toolbox → R scripts →User R scripts

18/06/2018 - Hands-on session: QGIS

Extending QGIS functionalities: Add a custom script to the Processing Toolbox 



Skills notebook

Activate basemaps from external providers for your QGIS project 

Search and download satellite imagery data from QGIS

Full preprocessing of multispectral satellite imagery with QGIS using both Plugins 
and Processing algorithms

Manipulate raster bands to compute graphical indicators and conditional rasters for 
analysing remote sensing data

Edit vector layers in QGIS and speed-up the editing of attributes using the Value 
Map option

Add a custom script into QGIS

18/06/2018 - Hands-on session: QGIS



✓ Click on the script name. Specify the image to be classified (use the multispectral raster 
layer from the Sentinel-2 imagery clipped on the working area), the shapefile containing the 
training areas, the attribute of the shapefile containing the classes, and a name for the 
output classified raster layer. Then press Run 
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Extending QGIS functionalities: Perform a supervised image classification for 
built-up areas
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Extending QGIS functionalities: Perform a supervised image classification for 
built-up areas

✓ The classified raster layer is saved in your local memory and added to your QGIS project

✓ Visually compare the obtained classification with the reference natural color imagery 
(clip.tif or wa_overview.tif) and the classified map obtained from the NDBI computation. 
Make your judgments
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Extending QGIS functionalities: Perform a supervised image classification for 
built-up areas

✓ To better outline the differences between the two classified layers, use the Raster 
Calculator  to compute the map of the differences (classified_layer1 - classified layer 2)

✓ We obtain a raster having 3 values (-1, 0, 1) depicting the pixel wise agreement of the two 
classifications



Skills notebook

Activate basemaps from external providers for your QGIS project 

Search and download satellite imagery data from QGIS

Full preprocessing of multispectral satellite imagery with QGIS using both Plugins 
and Processing algorithms

Manipulate raster bands to compute graphical indicators and conditional rasters for 
analysing remote sensing data

Edit vector layers in QGIS and speed-up the editing of attributes using the Value 
Map option

Add a custom script into QGIS

Perform a supervised classification with QGIS using custom geoprocessing scripts
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Hands-on session: QGIS

… Questions?

Daniele Oxoli

PhD Candidate & Research Fellow 

Politecnico di Milano - GEOlab

P.zza Leonardo da Vinci 32, 

20133 Milano (IT)
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